Availability for tenants running under us-west-1 region (North California)
Incident Report for Hasura
Postmortem

On February 23rd, 2022, between 16:59 and 17:26 (UTC), a partial outage occurred across the vast majority of our projects located in the us-west-1 (North California) AWS region. A sudden spike of traffic in this region triggered our autoscaling mechanism, but the response was not enough to handle the load due to a misconfiguration.  A fix was implemented quickly in order to address the issue. During this 27 minute window, the average downtime for a project was recorded to be 9 minutes (Roughly 66% availability).

Posted Feb 24, 2022 - 21:46 UTC

Resolved
This incident has been resolved. Further updates will be made here once an RCA is created.
Posted Feb 23, 2022 - 18:48 UTC
Monitoring
During period of instability, tenant availability was impacted between 17:00 UTC and 17:25 UTC. At this time, the Hasura Team is monitoring cluster performance.
Posted Feb 23, 2022 - 17:41 UTC
Investigating
Hasura Team is currently investigating issues with tenants running in the us-west-1 (North California) region. This issue started occurring at around 17:00 UTC.
Posted Feb 23, 2022 - 17:31 UTC