Intermittent errors with Metadata APIs
Incident Report for Hasura
Resolved
This issue is resolved.
Posted Apr 13, 2021 - 14:05 UTC
Monitoring
We've rolled out `v2.0.0-cloud.4` with the fix.
Posted Apr 13, 2021 - 13:33 UTC
Identified
Due to a bug in one of the recently added database observability features, there can be intermittent, unexpected errors in some of the metadata APIs. Specifically metadata actions, that causes a database source to be re-resolved. The bug is fixed, and we are in the process of rolling out the new version.

The bug first appeared in `v2.0.0-cloud.3` which was rolled out over the last 24hours.
Posted Apr 13, 2021 - 12:51 UTC